Nous vous aidons à dépanner votre flipper.
Aide à la réparation des éléments électroniques et mécaniques
-
Conseils, trucs, astuces et
partage de nos expériences sur la restauration esthétique des éléments
Plateau / Playfield / Peinture & retouche / Mylar / Vernissage
-
Cours collectif sur le dépannage et
l'apprentissage aux techniques
-
Support Vidéo, Techniques
Expositions, Salons etc...

Mai 2008 - 2020

Dépannage d'une carte Williams System 4 (Flash)

Page 1 sur 2 1, 2  Suivant

Aller en bas

Dépannage d'une carte Williams System 4 (Flash) Empty Dépannage d'une carte Williams System 4 (Flash)

Message par Slamtilt le Lun 27 Jan 2020, 15:10

Bien le bonjour !

Pour rendre service à un proche, j'ai un vieux Flash de famille actuellement dans mon atelier :-)
Système que je ne connais absolument pas ! Mais j'ai déjà commencé à bouquiner ^^

Bien,
La cpu ne semble pas démarrer.

J'ai déjà contrôler intégralement la carte Alim, elle est 100% OK (Me restera à changer les condos)
Comme évidemment, la cpu à laissé couler ses piles... Cela dit, elle ne semble pas avoir été fort touchée.

[Vous devez être inscrit et connecté pour voir ce lien]
[Vous devez être inscrit et connecté pour voir ce lien]

Le support à piles est mort, mais rien ne semble avoir coulé sur la carte...
En revanche, la driver vas m'en faire déguster, maiiiis, je devrais m'en sortir comme un grand ;-)

[Vous devez être inscrit et connecté pour voir ce lien]

La ou je coince c'est avec la CPU, si j'en crois les LED, elle démarre bien, mais si je regarde le jeu, nada !
Pas d'affichage, rien.

Dans mes bouquins je vois qu'on dit que souvent les ROMS d'origine sont nazes avec le temps, j'aurais voulu les vérifier, voir même les changer, seulement voilà, je suis incapable de les identifier :-(

D'une part je ne trouves pas la référence avec mon MiniPro, d'autre part, je ne sais pas de quel type d'eprom on parle au cas ou je dois en recommander...
La référence indiquée dessus semble être : AMI-7641-5

[Vous devez être inscrit et connecté pour voir ce lien]

Pourriez vous me guider un peu la dessus ?

Merci :-)
Slamtilt
Slamtilt
Membre actif
Membre actif

Localisation : Belgique
Nombre de messages : 361
Date d'inscription : 28/02/2015

Revenir en haut Aller en bas

Dépannage d'une carte Williams System 4 (Flash) Empty Re: Dépannage d'une carte Williams System 4 (Flash)

Message par noflip95 le Mar 28 Jan 2020, 08:12

Bonjour,

Tout d'abord, une remarque: tu as un condensateur de découplage qui est cassé, juste en dessous de l'emplacement IC14 Shocked C'est pas très grave, il ne sert à rien puisque IC14 n'est pas installé. Mais ça fait pas très propre. Plutôt que de d'embêter à le dessouder/remplacer, coupe le carrément, ca sera plus "beau".  Wink
[Vous devez être inscrit et connecté pour voir ce lien]

Pour les 7641, ce sont des ROM de 512x8.
Si tu cherche la doc du composant, elle est sur notre site.
Il est inutile de chercher à les reprogrammer, ou à les remplacer par un composant strictement équivalent. Ce sont des PROM, non re-programmables et il n'existe pas d'EPROM pouvant les remplacer telles quelles.

D'ailleurs tu dois les connaitre: ce sont les mêmes que les GAME PROM sur les premiers SYSTEM-80 GTB Twisted Evil Oui, c'est pareil que sur les tout premiers Spiderman, Panthera...

La solution pour les remplacer sur Williams, c'est de faire comme chez Gottlieb: une adaptation pour mettre des 2716 (ou mieux, des EEPROM 2816) à la place.

La petite différence, c'est qu'au lieu de remplacer 2 ROM chez Gottlieb, il faudra remplacer 3 ROM (IC21, IC22 et IC26) chez Williams. Mais finalement, la modification n'est guère plus compliquée.

Je n'ai pas trop regardé dans le détail, mais la transformation semble très bien détaillée sur cette page:
[Vous devez être inscrit et connecté pour voir ce lien]
A voir, car si tu veux remplacer tes 7641, il faudra obligatoirement modifier la carte.
Là, je ne pourrais t'aider plus, car on n'a pas ce genre de flip chez nous.

_________________


Thierry.
noflip95
noflip95
Modérateur
Modérateur

Localisation : Franconville (95)
Nombre de messages : 875
Age : 55
Date d'inscription : 12/09/2010

https://www.flipprojets.fr

Revenir en haut Aller en bas

Dépannage d'une carte Williams System 4 (Flash) Empty Re: Dépannage d'une carte Williams System 4 (Flash)

Message par Slamtilt le Jeu 30 Jan 2020, 10:38

Ah oui, je vois (Pas vu le condo cassé par contre... Very Happy)

Cela ne m'enchante guère de partir sur des modifs CPU quand on voit le résultat avec mes CPU Gottlieb... Mais je vais voir.

En fait la doc c'est l'ancienne de Marvin si je ne me trompes ;-) Je vais déjà bouquiner tout ça, et aviser ensuite...

Merci pour les précisions reçues déjà :-)
Slamtilt
Slamtilt
Membre actif
Membre actif

Localisation : Belgique
Nombre de messages : 361
Date d'inscription : 28/02/2015

Revenir en haut Aller en bas

Dépannage d'une carte Williams System 4 (Flash) Empty Re: Dépannage d'une carte Williams System 4 (Flash)

Message par Slamtilt le Dim 01 Mar 2020, 17:35

Bonjour,

Voilà un peu l'avancement de ce coté,
J'ai désoxydé la carte, viré tous les sockets Scanbe foireux là,
changer les connecteurs d'alim,
changer tous l'interconnect CPU/Driver, un travail pénible.
Convertit pour utiliser la Rom en 2716 le tout monté sur socket.

Que pensez vous du boulot accompli ? Cela vous semble propre ?

[Vous devez être inscrit et connecté pour voir ce lien]
[Vous devez être inscrit et connecté pour voir ce lien]

Seulement voilà... La carte ne démarre toujours pas.
En fait, si j'en crois la doc, si, la cpu devrait booter. (2 LED flashent un coup, puis OFF)
Mais pas de display. La doc m'oriente vers la RAM, mais je n'ai rien pour remplacer cette dernière, donc je voudrais être plus sur avant de repasser commande...

Autre truc étrange,
Si je mets les "flipper roms" que j'ai gravée moi même sur des 2716 neuve, alors la cpu ne boote plus !
Pourquoi... ?
Je sais que ce n'est pas le domaine du forum les Williams, mais on sait jamais qu'un membre puisse m'aider... J'en aurais bien besoin ^^
Je continues à chercher de mon coté,
au pire je peux aussi graver une eprom test de leon (souvenez vous le Hook :-D)
Peut-être me donnera t'elle un diagnostic plus clair ?

Merci, bonne fin de journée à vous :-)
Slamtilt
Slamtilt
Membre actif
Membre actif

Localisation : Belgique
Nombre de messages : 361
Date d'inscription : 28/02/2015

Revenir en haut Aller en bas

Dépannage d'une carte Williams System 4 (Flash) Empty Re: Dépannage d'une carte Williams System 4 (Flash)

Message par Slamtilt le Sam 07 Mar 2020, 16:28

Grrr,
J'avance ici, je touches au but je le SAIS !
Mais cela ne fonctionnes toujours PAS...

Avec la Rom test de Leon, j'ai des résultats qui disent bien que la CPU fonctionne !
Sauf que voilà,
Sur le banc de test elle démarre bien et à chaque coup, ainsi que les Tests LED tout est ok
SAUF QUE
Une fois replacée dans le flip, dans les Mêmes conditions exactement, PAF elle démarre plus...
J'ai les bons voltages (carte alim OK connecteurs changés etc)
Mais elle refuse catégoriquement de démarrer c'est un truc de fou ! (Driver pas branchée donc)
Qu'est ce qui peut expliquer un tel phénomène ???
Slamtilt
Slamtilt
Membre actif
Membre actif

Localisation : Belgique
Nombre de messages : 361
Date d'inscription : 28/02/2015

Revenir en haut Aller en bas

Page 1 sur 2 1, 2  Suivant

Revenir en haut


 
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum