panne carte son  bad girl Pixel
Un don de 1€ minimum (Frais paypal à votre charge)

Après la réception de votre don
Votre compte Premium sera activé

panne carte son  bad girl Pixel
Nous vous aidons à dépanner votre flipper.
Aide à la réparation des éléments électroniques et mécaniques
-
Conseils, trucs, astuces et
partage de nos expériences sur la restauration esthétique des éléments
Plateau / Playfield / Peinture & retouche / Mylar / Vernissage
-
Cours collectif sur le dépannage et
l'apprentissage aux techniques
-
Support Vidéo, Techniques
Expositions, Salons etc...

A Bientôt sur www.flipper.fr
Mai 2008

panne carte son bad girl

Aller en bas

panne carte son  bad girl Empty panne carte son bad girl

Message par marine le Ven 21 Juin 2019, 19:31

bonjour

afin de rejouer a mon bad girl plié depuis 7 mois ,a sa mise en route je constate que jais le son 
du plateau ,mais pas de son ambiance .
sur ma carte les tensions son bonne et la led clignote.

je me fait passer une carte son d'un bad girl et celle ci fonctionne parfaitement.
tous ceci avec ma carte auxiliaire et la nappe.

donc je remplace sur mon flip ma carte en panne 
 jais remplacé le  6116 qui était monté sur support  sans effet
jais aussi essayé les éprom de sons  sans effet

je précise que le son fonctionner parfaitement avant de le plier et a son remontage plus de son

mon problème et sur ma carte , Mais ou ?  Very Happy  d'avance merci

marine

Localisation : St pierre
Nombre de messages : 55
Age : 29
Emploi/loisirs : flipper
Date d'inscription : 27/03/2018

Revenir en haut Aller en bas

panne carte son  bad girl Empty Re: panne carte son bad girl

Message par noflip95 le Ven 28 Juin 2019, 11:07

Bonjour,

Ca fait un petit moment que je réfléchi à ce problème et je pense savoir ce qui déconne sur ta carte son.

Il faut dire que ce n'est pas si simple à comprendre. Ces cartes SYSTEM-80B de 3ème génération, comportent deux systèmes CPU quasi-indépendants l'un de l'autre.

  • Le système "Y" (T3/YROM) qui travaille avec les générateurs complexe type DSP (ici, la carte auxiliaire avec YM2151/YM3014).
  • Le système "D" (N1/DROM) qui est beaucoup plus  basique, utilisant un simple DAC (AD7528).

On pourrait penser que l'un des systèmes est dédié à la musique d'ambiance, et l'autre aux bruitages, mais en fait NON, il n'en n'est rien et c'est un peu mélangé au niveau utilisation.


En revanche, on connait le codage des commandes envoyées par la carte CPU et on peut en déduire une caractéristique essentielle. La carte audio est similaire à celle des SYSTEM-3,  qui utilisent des commandes sur 8 bits. Mais sur les SYSTEM-80B, seuls 5 bits sont utilisés (S16, S8, S4, S2 et S1).

En théorie, on peut avoir jusqu'à 2^5 = 32 commandes sons différentes. Mais historiquement, la détection ne se faisait que sur 4 bits, les commandes "00" et "10" sont inactives (ce qui laisse au final que 30 commandes audio).

Maintenant, ce qui est remarquable: c'est que sur le Bad Girl, les commandes 01..0F (donc avec le bit 4 à "0") correspondent à des bruitages, tandis que les commande 11..1F (avec le bit 4 à "1") correspondent à des musiques.

Idea Et ce qui se passe sur ta carte, c'est comme si le bit 4 était "ignoré" quand il est à "1"
. Ce n'est pas exactement comme si le bit était toujours vu à "0" (auquel cas on aurait des bruitages à la place de la musique), mais c'est un peu la même idée.

Sachant que Gottlieb travaille en logique négative, les commandes avec le bit 4 à 1 sont en fait celles avec le signal S16 mis à la masse.
Un coup d'oeil sur le schéma pour comprendre comment fonctionne la détection:
[Vous devez être inscrit et connecté pour voir ce lien]
Le signal "vert" correspond à la détection d'une commande. Il pilote les latches LS374, ainsi que les bascules LS74 pour envoyer une IRQ au deux CPU.
La détection se fait avec le 7430, qui regarde si une de ses entrées passe à la masse (je rappelle que l'on travaille en logique négative). Donc dès que l'on a une commande différente de 00. En fait, comme historiquement en SYSTEM-80B on est limité à 5 bits, et encore, avec détection sur 4 bits, le signal S16 doit être ignoré (donc mis au + via une resistance de tirage).
C'est le rôle des jumpers JP8 et JP7. En mode SYSTEM-80B, on doit avoir JP7 connecté et JP8 libre. Ainsi le 7430 va n'avoir en entrée que S8, S4, S2, S1 (toutes les autres entrées S128, S64, S32 et S16 sont ramenées au + via des resistances de tirage). En mode SYSTEM-3, comme tout est câblé, on doit rétablir le S16 en reliant JP8 et en retirant JP7.

Il faut savoir aussi, que sur les cartes de générations précédentes, tu avais des DIP à la place des jumpers:
[Vous devez être inscrit et connecté pour voir ce lien]

Pour que le système de détection avec le 7430 fonctionne, il faut impérativement passer par une période "inactive" (commande 00 ou 10 en SYSTEM-80B, commande 00 en SYSTEM-3).

Arrow Maintenant, que se passe t-il sur un SYSTEM-80B, mais donc la carte audio serait configurée comme pour un SYSTEM-3 Question

Eh bien, les commandes 01..0F seront correctement traitées. Car leur bit 4 est à "0", donc S16 est au +. Tous les autres bits ne sont pas reliés, donc mis au + par des resistances de tirage. Autrement dit, le 7430 va fonctionner correctement dans ce cas.

Par contre, pour les commandes 11..1F, leur bit 4 étant à "1" le S16 va être mis à la masse.
Et là, le 7430 ne va plus détecter de commande ! ou plus exactement, ne va plus pouvoir détecter de période de repos.



ArrowArrowArrow: Moralité : ta carte audio doit fonctionner en mode SYSTEM-3  Exclamation

Regarde simplement du coté des Jumpers/switches en entrée du 7430. Tu n'aurais pas une carte avec des DIP par hasard, donc l'un aurai été basculé par inadvertance ?
Ou alors, il y a un schmilblick (fil coupé, court circuit avec la masse ?) du coté du 7430.

_________________


Thierry.
noflip95
noflip95
Modérateur
Modérateur

Localisation : Franconville (95)
Nombre de messages : 862
Age : 54
Date d'inscription : 12/09/2010

https://www.flipprojets.fr

Revenir en haut Aller en bas

panne carte son  bad girl Empty bad girl

Message par marine le Lun 01 Juil 2019, 07:36

Bonjour

merci pour cette belle explication technique sur ma carte ,et bien sur tu as mis le doigt pil poil
sur ma panne .

pour commencer jais remplacé le 7430 monté sur support tulipe que mon Dad avait en stock
le résultat fut le même ,puis en regardant bien le plan et ton explication sur le JP7 et 8
je contacte que jais les deux sur ma carte,donc je retire le JP8 ,et la ma carte fonctionne parfaitement ,jais retrouvé le son . bizarre puisque le son fonctionné avant de le plier.

et bien jais compris pourquoi, avec mon père nous avons déposé faute de place 3 flip 80B
chez un " amis " qui possède également des 80B .et autre Gottlieb
donc vous avez compris ,MDR
si jais bien compris Thierry , nous avions une carte de systéme 3 !!!
bref , cette après midi ont récupère mes flippers chez son pote.

 le coté positif de tout ceci ,jais encore appris  quelque chose sur les cartes son Gottlieb.
et cette différence entre les deux système.
Merci a toi Thierry pour se cour sur la carte son ,j'aurais jamais trouver toute seul.

jais un dernier petit problème sur mon bad girl.
a la mise en marche du flipper par l'inter sous la caisse , le flipper démarre ,mais je n'ai pas l'afficheur ni les batteurs, je l'éteint et le rallume et tout fonctionne et ceci a chaque fois 
aussi a la mise en route la bille sort dans le couloir sans démarrer une partie
Fichiers joints
panne carte son  bad girl Attachment
DSCN3355-002.JPG Vous n'avez pas la permission de télécharger les fichiers joints.(151 Ko) Téléchargé 0 fois

marine

Localisation : St pierre
Nombre de messages : 55
Age : 29
Emploi/loisirs : flipper
Date d'inscription : 27/03/2018

Revenir en haut Aller en bas

Revenir en haut


 
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum