www.flipper.fr
Vous souhaitez réagir à ce message ? Créez un compte en quelques clics ou connectez-vous pour continuer.
Nous vous aidons à dépanner votre flipper.
Aide à la réparation des éléments électroniques et mécaniques
-
Conseils, trucs, astuces et
partage de nos expériences sur la restauration esthétique des éléments
Plateau / Playfield / Peinture & retouche / Mylar / Vernissage
-
Cours collectif sur le dépannage et
l'apprentissage aux techniques
-
Support Vidéo, Techniques
Expositions, Salons etc...

Mai 2008 - 2020
Derniers sujets
» bouton test sur class 1812
par danny60 Jeu 02 Juil 2020, 20:59

» Remise en route d'un COUNTERFORCE
par ced 07 Jeu 02 Juil 2020, 08:27

» nouveau proprietaire d'un flipper
par selmines Lun 29 Juin 2020, 13:30

» Révision carte alimentation Williams system 3
par flip78 Sam 27 Juin 2020, 12:12

» Williams "Contact" system 3
par Petitcurieux Jeu 18 Juin 2020, 20:14

» Sky Warrior - Kit Gottlieb I.D.I - System1
par Petitcurieux Mer 17 Juin 2020, 22:40

» prochain projet apres la revision du hot tip .restoration d un little chief williams
par Rocknroll 95 Ven 12 Juin 2020, 19:57

» flipper happy clown problème de raz
par Rocknroll 95 Ven 12 Juin 2020, 19:36

» Gottlieb "Gridiron" (1977)
par Petitcurieux Jeu 11 Juin 2020, 16:52

» restauration d un flipper Star Pool Williams
par ced 07 Dim 07 Juin 2020, 09:25

» Gottlieb Big House , besoin d'aide , parce que je seche
par maxhab Mer 03 Juin 2020, 14:40

» Faire un don pour le FORUM Hyper important
par Admin Lun 01 Juin 2020, 13:44

» Présentation Loreaumuche
par ced 07 Sam 30 Mai 2020, 12:37

» CPU 0 clignotement sur bally play boy
par eric-antoine Mar 26 Mai 2020, 10:02

» Problème affichage Whirlwind
par Fred02 Dim 24 Mai 2020, 18:27

» Restauration d'un shamerok
par ced 07 Jeu 21 Mai 2020, 09:14

» Je cherches un Manuel d'un Arena en PDF svp
par flipp61 Dim 17 Mai 2020, 10:04

» Bonjour je recherche la doc en PDF pour un flipper électronique ARENA svp
par toto8077 Mer 13 Mai 2020, 15:30

» Remise en route d'un Gottlieb "Torch"
par Petitcurieux Mar 12 Mai 2020, 22:19

» Révision de la carte d'alimentation A2, Gottlieb 80 et 80A
par Petitcurieux Dim 10 Mai 2020, 19:05

Qui est en ligne ?
Il y a en tout 34 utilisateurs en ligne :: 2 Enregistrés, 0 Invisible et 32 Invités

Petitcurieux, selmines

Le record du nombre d'utilisateurs en ligne est de 175 le Sam 31 Oct 2015, 10:03

Redémarrage williams sys3

Page 1 sur 4 1, 2, 3, 4  Suivant

Aller en bas

Redémarrage williams sys3 Empty Redémarrage williams sys3

Message par clems80 le Sam 07 Juil 2018, 02:40

Hello
Je suis en cour de redemarage d'un williams world cup de 1978 (williams system3) et apres avoir bien galérer pour faire booter la cpu, j'ai maintenant les lampe commandées qui n'on pas l'air de fonctionné, au demarage quelques une s'allume fixe et c'est tout, meme en lancant une parti les points se marque bien mais les ampoule sont figees.

J'ai deja fait pas mal de chose, tout en eprom 2716 avec ajout support en u14, condo du 5v changé, connecteur centrale change, tout les 74xx de la cpu change, 5101 changé, les condo changes, tout les support ci de cpu et driver changé/ajouté, des 6821-6116-6800 de recup pour faire des tests, les 7406 de la driver qui etait hs changes, les transistor de la driver testé ok, presques toutes les diode testé, bref pas mal de choses..


Ensuite il y aura un afficheur qui n'affiche pas tout les chiffre mais c'est pas l'afficheur en lui meme donc je verrai pour les ci de la carte afficheur principale par la suite. Et pas de son mais il faut encore que je test les tensions de celle-ci.

Je vous ai fait une petite video pour voir les symptome :
https://youtu.be/y6LIDPJ8w0w



##################################################################
##################     MAJ du 9/7/18  (fin page 1)  #######################
##################################################################

RESOLU:
cheers Eclairage commandé fonctionnel: en fait il n'y a pas d'attrac mode sur ce flippe ce qui m'a induit en erreur, et les ampoule qui ne réagisse pas sont du a des défaut de switch

Question switchs: certains sont non fonctionnel, et ceux sont les switchs de la colonne 4 (vert/jaune) donc je vais voir si il n'y a pas un problème de câblage, diode, résistance ou pia
--> il y avait un mauvais contact sur un fil de la prise entre le fronton et le plateau



NON RESOLU:

Question carte sons: non fonctionnel mais bouton test ok(musique de test) mais test de relier la masse sur les bornes de 10J3 pas de sons (quelques soit le réglage du switch 2 pour choisir le style de son), test d'un autre PIA6821 deja fait.
Après vérification a la sonde logique toutes les bornes de 10J3 sont a +5V sauf la 4 qui est a la masse, donc peut être un problème de puce tampon IC8 "4050"

Question display player 4: manque des chiffres, a voir mais il sagit surement d'une puce d’entrée 4069, je doit tester a la sonde logique

bobine upkicker b.g. et bumper g. : surement transistor hs sur driver, j'en ai trouver un qui était brulant tout a l'heure


Dernière édition par clems80 le Mer 11 Juil 2018, 21:56, édité 3 fois

clems80

Localisation : 80
Nombre de messages : 16
Date d'inscription : 25/06/2018

Revenir en haut Aller en bas

Redémarrage williams sys3 Empty Re: Redémarrage williams sys3

Message par noflip95 le Sam 07 Juil 2018, 18:17

Bonjour,

Je ne suis pas particulièrement (pas encore Rolling Eyes ) spécialiste des Williams SYSTEM 3, mais en voyant le schéma, la panne ne me semble pas très difficile à localiser.

En effet, sur ce système, les lampes commandées sont organisées dans une matrice avec d'un coté, les colonnes pilotant le + et de l'autre les rangées pilotant le -. Le tout est construit autour d'un PIA6821 (IC10) monté sur la carte driver.

► Puisque la carte CPU fonctionne (boot et affichage le prouvent), cela indique que toute la partie en aval et surtout, tout ce qui circule sur le grand connecteur J1 est bon. La partie "informatique", bus de données, adresses et contrôles est visiblement fonctionnelle(sinon, le reste ne marcherait pas). Pour les lampes, la panne se situe donc au niveau de IC10 ou après dans la partie "pure" driver.

► Pour que IC10 soit correctement adressé par le CPU, il faut que la logique de décodage fonctionne. Visiblement, c'est le cas. Les "chip select" de IC10 : CS0, CS1, CS2 sont pilotés directement par des adresses, ou par un combinaison avec le VMA (IC7). Comme c'est aussi utilisé par les autres circuits, on peut raisonnablement exclure ce problème, car si ça ne marchait pas il n'y aurait pas non plus de matrice de contact, ou de commande de solénoïdes. Donc, à priori, ce qui est en aval de IC10 semble correct. A moins qu'il n'y ait une piste coupée (une vérification à l'ohmmètre est facile) sur CS0/CS1/CS2, ca doit adresser correctement le 6821.

Redémarrage williams sys3 2018-011

◊ Pour dépanner, moi, ce que je ferai (sans avoir de banc de test sous la main):
- Je démonterai la carte driver pour pouvoir la tester tranquillement sur table.
- J'enlèverai IC10 (qui visiblement est monté sur support), pour pouvoir injecter "à la main" des signaux de commande sur les broches.
- j'utiliserai pour cela des petits fils (type "Dupont" mâle) pour relier soit VCC (+ 5) ou GND (masse), vers les broches des ports PA et PB, qui sont dédiés à la matrice des lampes.
- j'alimenterai ensuite la carte driver en 5 volts.

C'est pas très compliqué à faire, surtout que sur les 6821, les ports A, B et l'alim sont du même coté (broches 1 à 20).

Redémarrage williams sys3 2018-010

Ainsi, en injectant du "0", ou du "1" sur les broches des ports, on peut vérifier avec un simple voltmètre si les circuits fonctionnent.

Normalement, il n'y a pas besoin d'injecter du + sur le BLANKING car il y a une résistance de tirage au + sur la driver. Pour les alimentations des lampes, tu peux utiliser aussi du 5 volts (pour lamps VCC/GND) pour pouvoir vérifier les sorties des transistors.

→ Commencer d'abord par tester les strobes.
Contrôle ce qui arrive sur les 7408 (IC13 et IC14), pour voir si les circuits fonctionnenent. C'est des portes AND, elles servent justement à bloquer les commandes avec le blanking.
Ensuite, tu regarde si le Darlington 2N6427 pilote bien de la masse, et ensuite ce qui ressort après le TIP42 (doit y avoir du + 5 quand on pilote les lignes PBx avec du "1").

→ Teste ensuite de la même façon, les rows.
Là, c'est sur le port A... pareil, tu mesure ce qui passe au travers des inverseurs 7406, du Darlington 2N6427 et du 2N6162.

Mais avant de faire ces vérifications fastidieuse, tu peux juste essayer de remplacer le 6821 IC10, car si c'est lui qui déconne, c'est facile à vérifier.

_________________


Thierry.
noflip95
noflip95
Modérateur
Modérateur

Localisation : Franconville (95)
Nombre de messages : 881
Age : 55
Date d'inscription : 12/09/2010

https://www.flipprojets.fr

Revenir en haut Aller en bas

Redémarrage williams sys3 Empty Re: Redémarrage williams sys3

Message par clems80 le Dim 08 Juil 2018, 18:23

Bonjour
Merci pour ta reponse on ne peu plus detailler et precise.


J'ai essayer plusieur 6821 mais exactement pareil. 

Les 7406 sont neuf donc je vais essayer de changer les 7408, faut juste que je fasse un peu de soudure..

A la sonde logique sur les pattes des 7408 j'a du bagotage sur 1pates sur 2, je sais pas si c'est normal. 

Cs0 cs1 et cs2 sont les pattes a cote du +5v c'est ca ? Mais cs1 et cs2 sont censé etre relier ensemble ! ?

clems80

Localisation : 80
Nombre de messages : 16
Date d'inscription : 25/06/2018

Revenir en haut Aller en bas

Redémarrage williams sys3 Empty Re: Redémarrage williams sys3

Message par noflip95 le Dim 08 Juil 2018, 20:02

Bonsoir,

• Oui, le "bagotage" est normal sur le 7408. En fait, cela indique que le 6821 fonctionne (au moins partiellement, pour être sûr, la sonde logique est insuffisante, il vaudrait mieux l'analyseur logique - mais on s'en passera). En fait, le système balaye la matrice des lampes par les strobes, en les activant séquentiellement, un par un. Strobe0, puis Strobe1, ... et ainsi de suite.

• Donc le problème semble se situer après, soit effectivement les 7408 sont grillés, mais ça peut aussi venir des transistors qui sont derrière (Darlington et TIP). Le 6821 semble donc être correctement adressé, pas la peine de chercher sur les chip select. Pour info, non les CS1 et CS2 ne sont pas réliès ensemble - c'est vrai, le schéma n'est pas clair sur ce point.
Le 6821 est décodé quand :
- Le signal VMA (Valid Memory Address) et A13 sont a "1" (via la porte AND de IC7/7408 sur le CS0,
- et quand le signal A14 est à "0" (connecté sur le /CS2),
- et quand le signal A10 est à "1" (connecté sur le CS1).
Ca fait un décodage "simpliste" sur les adresses :
x01x x1xx xxxx xxxx
Soit 2400-2403 (avec bien sûr de nombreuses images sur l'espace adressable).

Sur le schéma, on voit effectivement A10 et A14 reliés ensembles  Shocked  ... bien sûr, c'est pas possible !!! En fait, c'est bien A10 qui vas vers CS1 et A14 qui va vers /CS2.
Mais bon, c'est pour info, vu que le 6821 semble fonctionner.

_________________


Thierry.
noflip95
noflip95
Modérateur
Modérateur

Localisation : Franconville (95)
Nombre de messages : 881
Age : 55
Date d'inscription : 12/09/2010

https://www.flipprojets.fr

Revenir en haut Aller en bas

Redémarrage williams sys3 Empty Re: Redémarrage williams sys3

Message par clems80 le Dim 08 Juil 2018, 20:21

Il faudrait que je me trouve un petit cour de fonctionnement des ci 6800 6821 en general car c'est une chose assez complexe que je n'est jamais approfondi.

Donc en theorie ca devrai fonctionne mais en pratique..

Donc j'ai dessoude les 2 7408, mis des support et les ai tester sur mon programmateur qui permet de tester les circuit logique et ils ont l'air ok  .  j'essaierai quand meme avec des neuf au cas ..
Et j'ai verifie les pistes par ci par la autour des support 40 broches mais ras.

clems80

Localisation : 80
Nombre de messages : 16
Date d'inscription : 25/06/2018

Revenir en haut Aller en bas

Page 1 sur 4 1, 2, 3, 4  Suivant

Revenir en haut


 
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum